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CHAPTER 1
INSTALLATION OF AI PROCTOR
1.0
Introduction
Installation chapter is divided into installation for Windows, MacBook, and Mobile Apps. AIProctor system for Windows consists of (1) a desktop application, and (2) a browser extension.
Meanwhile, Ai Proctor system for MacBook consists of a desktop application only. It is a must
conduct to conduct the exam using either Google Chrome or Microsoft Edge. The installation of
Ai Proctor Mobile Apps on mobile phone is necessary if the lecturer intends to use scanning
feature. It is compulsory for all students to install the Ai Proctor on their laptop.
Following the introductory section, Section 1.1 shows steps to install Ai Proctor system for
Windows. Section 1.2 exhibits steps to install Ai Proctor system for MacBook. Finally, the chapter
ends with the installation of Ai Proctor Mobile Apps on Android and iPhone.
1.1

Ai Proctor System for Windows

1.1.1

Desktop Application

1. Download the desktop application from https://ai-proctor-taylors.com/download/
2. Unzip the downloaded file

3. Double click on “AI_Proctor_Setup.exe”
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4. Wait until the setup window appears, then press “next” until the installation is complete

5. Complete the setup
Note: Do not select create a desktop shortcut and launch Ai Proctor

6. It is better to restart your computer after installation
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1.1.2 Install the Google Chrome extension
1. Open Google Chrome browser
2. Download the extension by copying this link, and paste it on Google Chrome address bar
https://chrome.google.com/webstore/detail/ai-proctor-moodle/nbhdcdolapnpbccipdpagdlgbhgpkjpd

3. Choose Add to Chrome

4. You can see the AI-Proctor-Moodle on Google Chrome extensions

Note: If you have any problem in accessing this page, go to Chrome extensions and search for
AI-Proctor-Moodle. Then follow the same steps
1. Click Google Chrome → Click 3 dots → Click More tools → Click Extension
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2. Click Extension → Open Chrome Web Store

3. Search box → Ai Proctor moodle

4. Add Ai Proctor – Moodle
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1.1.3 Install the Microsoft Edge add-on
1. Open Microsoft Edge browser
2. Download the extension by copying this link, and paste it on Microsoft Edge
https://microsoftedge.microsoft.com/addons/detail/aiproctormoodle/opdniicadebhjheijnio
nkckjkmkpomb
3. Choose “Get”

4. You should see the extension on the Edge browser

Note: if you have any problem in accessing this page, go to Microsoft edge add-on
https://microsoftedge.microsoft.com/addons/Microsoft-Edge-Extensions-Home
Search for AI-Proctor-Moodle. Then follow the same steps
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1.2

Ai Proctor System for MacBook

1.2.1

Install AI-Proctor on a MacOS laptop

1. Download the desktop application from the website (https://ai-proctortaylors.com/download/ )
2. Unzip the downloaded file
3. Double click on AI-Proctor_*.dmg , where * is the version number of the software
4. Move AI-Proctor to Applications folder

1.2.2

Allow Permissions for Recording and Accessibility

1. Open System preferences → Security & Privacy → “Privacy” tap

2. Open the lock
3. Scroll down to “Accessibility” → add “AI-Proctor” from the “+” sign
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4. Scroll down to “Screen Recording” → add “AI-Proctor” from the “+” sign
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1.3

Ai Proctor for Mobile Apps

1.3.1

Install the Ai Proctor mobile app – Android phone
1. Go to Android play store
2. Search for “AI Proctor”
3. Install
4. You will find the application in your apps

1.3.2

Install the Ai Proctor mobile app – iPhone
1. Go to iOS app store
2. Search for “AI Proctor”
3. Get
4. You will find the application in your apps
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CHAPTER 2
TAYLOR'S INTEGRATED MOODLE E-LEARNING SYSTEM (TIMES): SETTING UP
THE EXAM QUESTION
2.0
Introduction
TIMeS is the official e-learning platform for Taylor’s University students. All teaching and
learning materials, including slides, handouts, hypothetical cases, videos, assessments etc., can be
accessed from TIMeS platform. In addition, TIMeS is also a platform to conduct the online exams
for Taylor’s University.
This chapter consists of three sections. Section 2.1 illustrates steps to set the exam question. Next,
Section 2.2 exhibits steps to insert the exam question. Finally, Section 2.3 shows steps to edit the
question setting, if necessary.
2.1

Exam setting
1. Turn editing on

2. Add topic
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3. Rename topic - Online Exam (make sure to hide the topic from students)

4. Under the same topic → Add an activity → Select Quiz → Click add
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5. Name your quiz → Add description (if necessary) → Tick display description on
course (if necessary)
Note: Please remember the Quiz name

6. Update the Quiz setting: Timing, Grade, Layout, Question behaviour, Review option.
- Timing – set time required to complete the question; Grade – attempt allowed to
students, etc. (you can explore to suit your exam requirement)

Note: Timing and Restrict access are the most important setting.
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7. Go to Restrict access → Click Add restriction → Select Ai Proctor
Note: If you hide the topic, you will not see the Ai Proctor icon

8. Click Save and display
2.2

Insert exam question
1. Click on the exam name – Question 1
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2. Click Edit quiz

3. Add a new question: Click Add → Select a new question

4. Choose a question type to add → Click add button.
Note: It is suggested to select ‘essay’ question. It will show the question in a single page.
However, it depends on lecturers to choose question type that is suitable for their module.
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5. Insert exam question

6. Go to Response Options → Click Allow attachments → Select no. of attachments →
Click Required Attachments → Selection no. of attachments
Note: Response format is the setting for the response/answer box. You can disable the
response/answer box by selecting the No Online Text.

7. Click Save changes
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2.3

Edit settings

2.3.1

Edit settings

1. Edit setting

2.3.1

Edit quiz

1. Administration bar → Edit Quiz
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2.3.3 Question with auxiliary table
Step 1

Step 2
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CHAPTER 3
AI PROCTOR
3.0

Introduction

Ai Proctor is a platform for lecturers to monitor student’s screen and cam activities. Hence,
invigilation of online exams will be done using the Ai Proctor platform. Lecturers are required to
login to Ai Proctor website to conduct the invigilation task. It needs to be highlighted that students
are not required to have an Ai Proctor account.
Chapter 3 consists of three sections. Section 3.1 exhibits steps to set the exam environment. Section
3.2 shows steps to conduct the invigilation task. Finally, this chapter ends with Section 3.3 which
illustrates steps to generate report after completing the online exam.

3.1

Modify the event
1. Go to https://ai-proctor-taylors.com/users/login/ → Login using the username and
password → Click Forgot Password → Change your password
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2. Go Classes → Click External Class → To view your exam page

Note: You will have another folder known as ‘Invigilator’ if you have become the
invigilator.

3. Click External Class → Search for your exam name → Click your exam

4. Modify Exam → Click Modify the Event
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5. Modify the event accordingly → click modify

Note:
1. Event info: any comments of description about the event (If necessary)
2. Invitation URL: Leave it blank
3. Microphone usage: if the instructor would like AI-Proctor to detect any human speech
around the students, enable use microphone.
4. Face Recognition: AI-Proctor can make sure that the same student that starts and ends
the exam.
5. Record type: AI-Proctor can record a video for the laptop camera (showing the face
of the student), and the student’s laptop screen. There are three options available: (1)
No record: no recording will be done, (2) record only last 5 mins: this is a good option
if the instructor is worried only about the last part of the exam when usually students
try to increase their unethical behavior due to the end of exam anxiety, (3) full
recording, where the whole session is recorded. Note that recording means that more
traffic is required between the student’s desktop and the proctoring server. If the
network at the majority of students is not good, then the last 5 mins option can be a
good choice
6. Allowed websites: AI-Proctor allows the students to open some whitelist websites
during the exam that can contain some formulas, information, and others. The full web
address of the website (including http, https) can be written in this box. If a whole
domain is allowed (main page and all subpages), then an (*) must be added. For
example, to access all webpages in Wikipedia, write https://en.wikipedia.org/*
7. Allowed programs: If your exam needs access to a certain program, then you can write
the name of this program in the whitelist applications. In order to get the correct name
that should be added here, open the application, and get the name of the application
from the title bar.
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6. Information after modifying the event

7. Multiple invigilator
a. Upload list of students in the excel format onto Ai Proctor
b. Download list of invigilators file in the excel format from Ai Proctor → click ‘Use this
template’
c. Upload updated list of invigilators in the excel format onto Ai Proctor.
d. Click Split
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3.2

Invigilation Task

3.2.1

Before the exam
1. Click Student Request
Note: Students may have issue with microphone or cam. They are allowed to send a
request to enter the exam without microphone or cam.

3.2.2

During the exam
1. Click Proctor The Event
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2. Interface
Note: Offline means students have launched the Ai Proctor. But they are still at the testing
stages. When they have gone through the testing stages, they will become Online Students.

Note:
Examples of academic misconduct
a. Open word file
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b. Open lecture slide

c. Web browser
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d. Talking during exam

24

e. Leave exam station or no face detection

Overall interface
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3. Monitor Students

4. Chat with students
a. Broadcast message to all students
Note: Broadcast message can be done through ‘Proctor the Event’. You cannot send a
message to all students through chat room.
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b. Personal Chat
Note: You should see green light to indicate student is still doing the exam.

Note: Ai Proctor will open each menu (Proctor the Event, Chat Room, etc.) in a new tab.

3.2.3

After the exam
1. You will have different interface.
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2. Generate report → Click on Reports

Note:
1. After the end of the exam, you will get a list of all students with their cheating attempts
sorted according to the total cheating duration during the exam. From this page, you can
choose to download all the reports all reports or records, all reports, all records, or only
download the reports or records of certain students.
2. Click download: Download all or download student by student
a. Instructor will get an Excel file with a summary of all cheating events of the students,
and a folder for the cheating events/records for every student

b. Inside each folder of each student, an excel file showing the details of the cheating
events. The cheating types are on the left. The 4 types are:
a. Browser: open a website.
b. Program: open a program.
c. Audio: someone talking around the student
d. Face: if can’t be detected in front of the screen, or if multiple faces are
detected by the camera
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c. A video including the cheating event is downloaded to the student folder. The
recordings are also downloaded to the folder if they were requested to be downloaded
during the exam
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CHAPTER 4
CONDUCTING ONLINE EXAMS
4.0
Introduction
Online exams will be conducted with only one click through TIMeS platform. There is no
requirement for students to have the Ai Proctor account. Nevertheless, it is compulsory for the
students to install the Ai Proctor before they are allowed to attempt the online exam.
There are three major sections in this chapter. Section 4.1 shows the way to ensure Ai Proctor has
been successfully install on the laptop. Section 4.2 exhibits steps to conduct an online exam using
Windows. Finally, Section 4.3 shows steps to conduct an online exam using MacBook.

4.1

Checking the installation of AI-Proctor
1. Checking the AI-proctor is installed on the laptop
Go to settings and select apps, you can see the app there

2. Check the installation of Google Chrome extension → click the extensions → check AIProctor-Moodle
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4.2
4.2.1
1.
2.
3.

Conducting an exam - Windows
Access the exam
Login to your TIMeS account
Go to the Topic of the exam
Go to the exam set by the instructor

4.2.2 Launch the AI-Proctor application
1. Click on AI proctor (blue button)

2. Then click on “open AI proctor desktop app” button

3. After launching the application, the system will connect the browser with the extension.
4. Click on continue
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4.2.3 Audio, face, and system checks
1. After clicking on continue, it goes directly into the audio testing

2. If the audio testing pass, it goes directly to scan face page

3. Click on “face scan” button, then set your face inside the green box and click on “scan
image”
Note: Make sure to place the face inside the green box. Please avoid a messy background.
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4. Click on continue

5. After clicking on continue, the system will do some checking to make sure no second
screen is connected and some other system checks
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4.2.4 Starting the exam
1. It will open the exam in the full screen mode
Note: The background of the screen is the exam page with full screen mode.

2. Press “Attempt Quiz now” on the exam page, the AI-Proctor window will be smaller and
on the top of the screen
Note: Ai Proctor window will become a small window

4.2.5 Access menu options
1. From the menu on AI-Proctor, you can generate an empty word/excel file for writing
your answers.

2. After generating word/excel file, you can use ALT+Tab to switch between exam page
and word/excel file
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3. If needed, you can copy the question from exam page to the word file
•
Select the question

•

•

Right click and choose copy

Press ALT+Tab to go back to the word/excel file, then paste the question

4. After you write your answer, you are required to click save. When you close the file, it
will be saved in C:\AI-Proctor Exam\”quiz name”
Note: Do not click “save as”. Please use only “save” icon or press the buttons (Ctrl + s)
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-

Close the file

Note:
Re-open any closed word/excel file (if needed)
1. If you need to re-open the word/excel file to edit
- generate a new word/excel file from the menu on AI-Proctor.

-

Then from the new word/excel file open the previous word/excel file
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2. Please ignore the warning message. All warnings are reviewed by instructor to make sure if the
student is focusing on exam or doing something wrong

4.2.6

Upload and submit answer file
1.

Upload the word/excel file generated from AI-Proctor, the path will be in
C:\AI-Proctor Exam\”quiz name”
Note: Do not rename the file. Please upload the file with its default name

2. After uploading your answers in TIMeS, click on finish attempts, then click on Submit all
and finish

3. The AI-Proctor will return into normal size.
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4. After ending the session, close the AI-Proctor from the “x” icon

1

4.3
Conducting an exam - MacBook
4.3.1 Checking the installation
1. Go to your Applications folder and check that the AI-Proctor is existed
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4.3.2

Access the exam
1. Login to your TIMeS account
2. Go to the Topic of the exam
3. Go to the exam set by the instructor

4.3.3 Launch the AI-Proctor application
1. Open your browser and login to your times.taylors.edu.my account
2. Go to your course page and scroll down to your Quiz name

3. A new page will open with this pop-up window, please choose “open AI-Proctor” to
launch the app.

4. The application will be launched with a brief privacy policy; you need to accept by click
on “Continue” button.
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5. Then you will need to click on “next” button on Audio test step, to allow the application
to access the microphone during the exam.

6. You will need to do “face scan” to get a reference profile picture of you.

7. Please put your face inside the center of the green box, then click on “Scan Image”
button, and allow for camera permission.
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8. If the application could get a clear front face image, it will allow you to click on
“Continue” button.
9. The exam page will be opened. You will be required to login with your account.
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4.3.4

Starting the exam
1. After login you can click on “Attempt Quiz now” -> start attempt to start the exam

2. The timing will start, and you will be able to generate word/excel files or make
private chat with the instructor. Access these options from there.
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3. Generate a word/excel file then write your answer, then save and close it.
⚫

Don’t use save as, use only save icon
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⚫

Close the file

4. You can back to the exam page by clicking on AI-proctor icon
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4.2.5

Upload and submit answer file
1. Upload the file to the exam page if needed form the upload button on the exam.
The default path will be “home directory/AI-Proctor Exam/Quiz name/”
Note: “home directory” folder will be with the name of your device

2. After uploading your answers in TIMeS, click on finish attempts, then click on
Submit all and finish
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3. Close the AI-Proctor from the “x” icon
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CHAPTER 5
SIMULATION OF ONLINE EXAMS
5.1

Testing and Monitoring the online exam examination
1. Student: Attempt exam → Click Ai Proctor (blue button)
Lecturer: Waiting for students to attempt quiz

2. Student: Click Open Ai-Proctor Desktop App
Lecturer: Waiting for students to attempt quiz
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3. Student: Read T&C policy → Click Continue
Lecturer: Waiting for students to attempt quiz

4. Student: Audio testing and Face verification
Lecturer: Waiting for students to attempt quiz

Note: The processes to enter the exam page take around 1 – 2minutes.
5. a. Student: Picture 1 → (1) Attempt quiz now → (2) Start attempt → Exam page →
Picture 2
Picture 2: (1) Exam question; (2) Timer
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b. Lecturer: Lecturer can see “Online Student” once the students “start attempt”
Picture 1: Online Students – students who are attempting the exam question.
Offline Students – students who have attempted the exam question but got
disconnected.
Picture 2: Click Student name – Monitoring activity
1. Screen monitoring; 2. Face monitoring; 3. Mobile monitoring (blank = OFF); 4.
Mobile app – red = OFF; 5. Webcam – green = ON
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6. Student: Exam page and generate word/excel file
a. Click menu → choose answer file → Word file
Ai Proctor automatically generates a word/excel file with student name (red line), exam
name (yellow line), and 4 digits number (green line).

b. The screen is locked by Ai Proctor. Students cannot place exam page (chrome
browser) and word file side to side.
Option 1: Students can only minimize word file accordingly to see the exam question.

Option 2: Student can copy and paste the exam question from the exam page into the
generated word/excel file.
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Note:
1. Please turn off Full screen pop-up with some JavaScript security to allow copy
and paste function (refer to SOAF – Online Examination Manual Guide, Section 1,
Part A, step 7).
2. Ai Proctor will encrypt the word/excel file once the exam is over. This is to ensure
that the confidentiality of the exam question is preserved. Students cannot reopen the
answer file.

c. i. Student: Scanning hand-written document
Students must install Ai Proctor mobile app → Android users: Play Store; iOS users:
Apple Store
PC and mobile must connect to the same Wi-Fi.
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1. Tap Start to enable Ai Proctor mobile app (Picture 1) → Mobile app is working
(Picture 2)
Picture 1 = HP screen (yellow border represents hp screen; Picture 2 = Laptop
screen

2. Click scan image → Click Ok → Done
Note: Ai proctor will convert the scanned image into a pdf document with student
name, exam name and 4 digits number.

c. ii. Lecturer: Scanning hand-written document
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Picture 1: Lecturer is monitoring student’s activities through (1) laptop screen, (2)
webcam, and (3) mobile app.
Note:
4 = Mobile app → Green = On; Red = Off = blank screen
5 = Webcam → Green = On; Red = Off
Picture 2: Lecturer can see through (2) the webcam that the student is scanning the handwritten document using (3) the mobile app. Laptop screen (1) shows the students’
activities on the laptop screen.

7. Student: Submit answer file
a. Click Attachment icon → Choose File → This PC → C Drive → Ai Proctor Exam
Folder → Click exam folder (remember quiz name) → Select File (word/excel file or
scan document) → Open → Upload this file → Done
Note: If students try to upload another word file which is not generated by Ai Proctor,
Ai Proctor will send an alert to the lecturer.
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b. Click Finish attempt → Submit all and finish → Done

Note: When the exam is over, the answer files (word/excel) will be encrypted by Ai Proctor.
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8. Lecturer: Download answer file
a. From TIMeS: Click Exam name → Click Attempt → Click Review attempt → Click
file to download

b. In case students do not upload the answer file on time. Lecturers can still get their
answer file from Ai Proctor Report.
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Go to Ai Proctor → Click Report → Download

Lecturers can find the answer file inside the report folder.

57

Other resources: Video guide

YouTube video:
Installation
Windows:
https://www.youtube.com/watch?v=ERv4Hrcu5cY
MacBook:
https://www.youtube.com/watch?v=12OKKb2F3bs
Conducting exams using Ai Proctor
Windows 10:
https://www.youtube.com/watch?v=8hlMoKHkeYY
MacBook:
https://www.youtube.com/watch?v=G4x46GyVcmE
Demo video for mobile app, showing the mobile stream and scan features
https://drive.google.com/file/d/18DhnG7EXTsyG0XMI5n9OF_977eWqkD5w/v
iew?usp=sharing
Manual Guide:
https://drive.google.com/drive/folders/1reYWqMClk6mwwCuLhqiBvCC82wfGzUO
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End of document. Thank you.
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